日. 6月 26th, 2022

TL;DR

awsコマンドを実施中に遭遇。versionが求められているものと違うようだ。

Encountered while executing aws command. The version seems different from what is required.

ERROR: boto3 1.9.226 has requirement botocore<1.13.0,>=1.12.226, but you'll have botocore 1.13.37 which is incompatible.

対処 deal

awscliを最新にする

Update awscli

pip3 install awscli --upgrade --user

 

その後、botocore、boto3をuninstall

Then uninstall botocore, boto3

pip3 uninstall botocore

pip3 uninstall boto3

 

再度botocore、boto3をinstall

Install botocore and boto3 again

pip3 install botocore

pip3 install boto3

 

以上。

That’s it.

参考情報 FYI

https://stackoverflow.com/questions/51911075/how-to-check-awscli-and-compatible-botocore-package-is-installed